<!DOCTYPE html>
<html lang="en" dir="ltr"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head>
<meta charset="utf-8" />
<link rel="shortcut icon" href="http://www.harddeadlines.com/sites/all/themes/responsive_blog/favicon.ico" type="image/vnd.microsoft.icon" />
<meta property="fb:app_id" content="214023788615295" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="description" content="The Portsmouth, RI Democratic Town Committee, at their monthly meeting on July 5, 2018, unanimously adopted a resolution urging the state Democratic Party to review how general assembly candidates are endorsed and create a plan to improve the process.&lt; /p&gt; &quot;The members of the Town Committee expressed their disappointment in the way endorsements were handled by the State Party" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="http://www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" />
<link rel="shortlink" href="http://www.harddeadlines.com/node/2387" />
<title>Portsmouth Democrats urge State Party review of endorsement process | hard deadlines</title>
<link type="text/css" rel="stylesheet" href="http://www.harddeadlines.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.harddeadlines.com/sites/default/files/css/css_8_Y7jPCAw1ScqXCiQ-XfkDvXAxOg8GwRT8En9MJ4_rQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.harddeadlines.com/sites/default/files/css/css_ZuNHGfxZFTUtLgKo8Gf7qz7QfFWwkCVcBbZCJUSPZCs.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
#fbcomments,.fb-comments,.fb-comments iframe,.fb-comments span{width:100% !important;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://www.harddeadlines.com/sites/default/files/css/css_4soGugrM6SD4Ywz0_5tdsGe-4J3ROxqF5vMLig_IwOM.css" media="all" />
<script type="text/javascript" src="http://www.harddeadlines.com/sites/default/files/js/js_x0MhBQfHNAIO1NwkQgzf_TGN4b8eMmKre3nqUfoQv3w.js"></script>
<script type="text/javascript" src="http://www.harddeadlines.com/sites/all/modules/lightbox2/js/lightbox.js?1531114892"></script>
<script type="text/javascript" src="http://www.harddeadlines.com/sites/default/files/js/js_Ta9yzC_Os8ve0q9RE0JgG5KbAIEKSe2V9WRhWM9GEME.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-39604024-1", {"cookieDomain":".harddeadlines.com"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="http://www.harddeadlines.com/sites/default/files/js/js_Y9qAQ_aUVVAWt11FYldlmyby8xdq_pWE7BbnEDjHMWA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"responsive_blog","theme_token":"zKLmTabE1hPTk7UUShf6WOxwuhoENHPNJdT0cLO3sOA","js":{"sites\/all\/modules\/jquery_update-2\/replace\/jquery\/1.8\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/lightbox2\/js\/lightbox.js":1,"sites\/all\/modules\/service_links\/js\/facebook_share.js":1,"sites\/all\/modules\/service_links\/js\/twitter_button.js":1,"sites\/all\/modules\/service_links\/js\/google_plus_one.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"0":1,"sites\/all\/themes\/responsive_blog\/js\/main-menu.js":1,"sites\/all\/themes\/responsive_blog\/js\/pngfix.min.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"modules\/book\/book.css":1,"modules\/comment\/comment.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/lightbox2\/css\/lightbox.css":1,"0":1,"sites\/all\/themes\/responsive_blog\/css\/dark.css":1,"sites\/all\/themes\/responsive_blog\/style.css":1}},"lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)public:\/","default_image":"\/sites\/all\/modules\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.8","overlay_color":"000","disable_close_click":true,"resize_sequence":0,"resize_speed":400,"fade_in_speed":400,"slide_down_speed":600,"use_alt_layout":false,"disable_resize":false,"disable_zoom":false,"force_show_nav":false,"show_caption":true,"loop_items":false,"node_link_text":"View Image Details","node_link_target":false,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003Ca href=\u0022#\u0022 onclick=\u0022hideLightbox(); return FALSE;\u0022\u003E\u003Ckbd\u003Ex\u003C\/kbd\u003E\u003C\/a\u003E to close","download_link_text":"","enable_login":false,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"()","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":true,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":5000,"slideshow_automatic_start":true,"slideshow_automatic_exit":true,"show_play_pause":true,"pause_on_next_click":false,"pause_on_previous_click":true,"loop_slides":false,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":false},"ws_fs":{"type":"button","app_id":"214023788615295","css":"vertical-align:top;margin-top:-4px"},"ws_gpo":{"size":"medium","annotation":"none","lang":"en_US","callback":"","width":100},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":1},"urlIsAjaxTrusted":{"\/2018\/07\/06\/portsmouth-democrats-urge-state-party-review-endorsement-process":true}});
//--><!]]>
</script>
<!--[if lt IE 9]><script src="/sites/all/themes/responsive_blog/js/html5.js"></script><![endif]-->
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-2387 node-type-blog white">
    <div id="wrapper">
  <header id="header" class="clearfix">
          <hgroup id="site-name-wrap">
        <h1 id="site-name">
          <a href="/" title="Home">
            <span>hard deadlines</span>
          </a>
        </h1>
        <h2 id="site-slogan">hyperlocal portsmouth</h2>      </hgroup>
                      <div class="social-profile">
        <ul>
          <li class="facebook">
            <a target="_blank" title="hard deadlines on Facebook" href="http://www.facebook.com/jmcdaid">hard deadlines Facebook </a>
          </li>          <li class="twitter">
            <a target="_blank" title="hard deadlines on Twitter" href="http://www.twitter.com/jmcdaid">hard deadlines Twitter </a>
          </li>              		<li class="you-tube">
            <a target="_blank" title="hard deadlines on YouTube" href="http://www.youtube.com/user/jmcdaid/">hard deadlines YouTube </a>
          </li>                    <li class="linkedin">
            <a target="_blank" title="hard deadlines on LinkedIn" href="http://www.linkedin.com/in/jmcdaid/">hard deadlines LinkedIn </a>
          </li>                    <li class="rss">
            <a target="_blank" title="hard deadlines in RSS" href="/rss.xml">hard deadlines RSS </a>
          </li>
        </ul>
      </div>
        <nav id="navigation" role="navigation">
      <div id="main-menu">
        <ul class="menu"><li class="first leaf"><a href="/" title="Home">Home</a></li>
<li class="leaf"><a href="/fiction" title="Science fiction, actually...">Fiction</a></li>
<li class="leaf"><a href="/papers" title="Academic and otherwise">Papers</a></li>
<li class="leaf"><a href="/music" title="Free mp3s and lyrics">Music</a></li>
<li class="leaf"><a href="/edu" title="Educational materials">Edu</a></li>
<li class="last leaf"><a href="/about/me" title="About the author">About</a></li>
</ul>      </div>
    </nav>
  </header>

  <div id="preface-area" class="clearfix">
    
      </div>

  <div id="main" class="clearfix">
    <div id="primary">
      <section id="content" role="main">
        
        <div id="breadcrumbs"><h2 class="element-invisible">You are here</h2><nav class="breadcrumb"><a href="/">Home</a> » <a href="/blog">Blogs</a> » <a href="/blogs/john-mcdaid">John McDaid&#039;s blog</a> » Portsmouth Democrats urge State Party review of endorsement process</nav></div>                        <div id="content-wrap">
                    <h1 class="page-title">Portsmouth Democrats urge State Party review of endorsement process</h1>                                                  <div class="region region-content">
  <div id="block-system-main" class="block block-system">

      
  <div class="content">
                        <span property="dc:title" content="Portsmouth Democrats urge State Party review of endorsement process" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span>  
              <span class="submitted">
        By <span rel="sioc:has_creator"><span class="username" xml:lang="" about="/users/john-mcdaid" typeof="sioc:UserAccount" property="foaf:name" datatype="">John McDaid</span></span>  |  <span property="dc:date dc:created" content="2018-07-06T13:05:50-04:00" datatype="xsd:dateTime">Friday, 6 July 2018</span>        </span>
      
    
  <div class="content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><img alt="" src="http://harddeadlines.com/sites/default/files/Screen%20Shot%202018-07-06%20at%207.43.54%20AM.png" style="float:left; height:202px; width:250px" />The Portsmouth, RI Democratic Town Committee, at their monthly meeting on July 5, 2018, unanimously adopted a resolution urging the state Democratic Party to review how general assembly candidates are endorsed and create a plan to improve the process.&lt; /p&gt;</p>
<p>"The members of the Town Committee expressed their disappointment in the way endorsements were handled by the State Party in the current election," said Town Committee Chair Len Katzman. "While we are encouraged by the two endorsements which were rescinded on Thursday, we feel that there are systemic issues which still need to be addressed. We want all Democrats to be able to trust the process."</p>
<p>The resolution urges the state committee to craft a plan to proactively educate all Democratic candidates about the procedures and timelines involved in endorsement, as well as taking steps to improved the transparency and accountability of the process.</p>
<p>Full text of the resolution:</p>
<blockquote><p><strong>Resolution urging the State Democratic Party to review&nbsp;and improve candidate endorsement process</strong></p>
<p>WHEREAS, the Portsmouth Democratic Town Committee, as an on-the-ground arm of the Democratic Party has a compelling interest in fairness and transparency in all Party activities as well as preserving the image and value of the Party locally; and</p>
<p>WHEREAS, the 2018 State Party endorsement process for general assembly candidates has resulted in negative impact on incumbent Democratic elected officials, endorsement of candidates with questionable credentials, allegations of unfair treatment, and harsh national media coverage; and</p>
<p>WHEREAS, the State Party has a responsibility to uphold both the integrity of the endorsement process and the image of the State Party as aligned with Democratic values;</p>
<p>THEREFORE BE IT RESOLVED that the Portsmouth Democratic Town Committee hereby calls upon the officers and staff of the Rhode Island Democratic Party to engage in a review and produce a plan to educate all Democratic candidates about procedures and timelines, and improve the transparency and accountability of the endorsement process.</p>
<p>LET IT BE KNOWN that this resolution was unanimously adopted by the Portsmouth Democratic Town Committee on the 5th day of July, 2018.</p>
</blockquote>
<p>[<a href="http://harddeadlines.com/sites/default/files/PDTC_Resolution_on_endorsements.pdf" target="_blank">view as pdf</a>]</p>
<p>"The members of the Town Committee are proud Democrats," said Katzman. "We believe that the State Party needs to do whatever is needed to ensure that all Democrats feel confident that the endorsement process has integrity."</p>
<p><em><strong>Editorial note: </strong>Written from a news release.</em></p>
</div></div></div><div class="field field-name-taxonomy-vocabulary-1 field-type-taxonomy-term-reference field-label-inline clearfix"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><div class="myTags"><a href="/taxonomy/term/16">02871</a>, <a href="/taxonomy/term/4">Localblogging</a>, <a href="/taxonomy/term/164">Portsmouth Democrats</a>, <a href="/taxonomy/term/107">Dems</a></div></div></div></div><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) {return;}
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script>
<div class="fb-comments fb-comments-fluid" data-href="http://www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" data-num-posts="15" data-width="100%" data-colorscheme="light"></div>
  </div>

      <footer>
      <ul class="links inline"><li class="service-links-facebook-share first"><a href="http://www.facebook.com/sharer.php" title="Share this post on Facebook" class="service-links-facebook-share" rel="http://www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" target="_blank"><span class="element-invisible">Share on Facebook</span></a></li>
<li class="service-links-twitter-widget"><a href="http://twitter.com/share?url=http%3A//www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process&amp;count=none&amp;via=jmcdaid&amp;text=Portsmouth%20Democrats%20urge%20State%20Party%20review%20of%20endorsement%20process&amp;counturl=http%3A//www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" class="twitter-share-button service-links-twitter-widget" title="Tweet This" rel="nofollow" target="_blank"><span class="element-invisible">Tweet Widget</span></a></li>
<li class="service-links-google-plus-one"><a href="http://www.harddeadlines.com/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" title="Plus it" class="service-links-google-plus-one" rel="nofollow" target="_blank"><span class="element-invisible">Google Plus One</span></a></li>
<li class="blog_usernames_blog"><a href="/blogs/john-mcdaid" title="Read John McDaid&#039;s latest blog entries.">John McDaid&#039;s blog</a></li>
<li class="comment_forbidden"></li>
<li class="statistics_counter last"><span>306 reads</span></li>
</ul>    </footer>
  
    </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
        </div>
      </section> <!-- /#main -->
    </div>

          <aside id="sidebar" role="complementary">
       <div class="region region-sidebar-first">
  <div id="block-block-1" class="block block-block">

        <h2 >John G. McDaid</h2>
    
  <div class="content">
    <style type="text/css">
.headquote {
font-color: #898989;
font-size: .85em;
line-height: normal;
margin: 0;
}
.headquote {
font-color: #898989;
font-size: .85em;
line-height: 80%;
text-align: right;
font-style: italic;
margin: 0px 35px; 0px 0px;
}

</style><p align="center"><img src="/sites/default/files/head_home.jpg" alt="Headshot" width="155" height="130" align="center" /></p>
<p></p>
<p class="headquote">"Transparency is the new objectivity"</p>
<p class="headquote">&mdash; David Weinberger</p>
<!--<p align="center"><p><img src="/jmcdaid/files/no-tent-home.jpg" alt="OUT OF THE TENT" width="168" height="114" align="center" /><br />
<span class="submitted">Out of the Tent <br /> and into the Booth!</span></p>
<p>--></p>
<!--<p align="center"><p><img src="/jmcdaid/files/head_home_simpson.jpg" alt="Headshot" width="155" height="129" align="center" /><br />
<span class="submitted">See the <a href="http://www.google.com/movies?hl=en&amp;near=02871&amp;dq=movies+02871&amp;mid=1adffc80e911521f&amp;sa=X&amp;oi=showtimes&amp;ct=movie-link&amp;cd=1" target="_blank">Simpsons Movie</a>, and join the fun at <a href="http://simpsonizeme.com/" target="_blank">SimpsonizeMe.com</a>.</span></p>
<p>old title: Inside the writer's brain.</p>
<p></p>
<iframe src="https://pledge.mayday.us/embed.html" width="260px" height="260px" frameborder="0" scrolling="no" > </iframe><p>--></p>
  </div>
  
</div> <!-- /.block -->
<div id="block-search-form" class="block block-search">

      
  <div class="content">
    <form action="/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-dyeW4KJ-mjP7EXjB3zV5_jsXbkb31hMcqJZiYB5y1IU" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>
  
</div> <!-- /.block -->
<div id="block-blog-recent" class="block block-blog">

        <h2 >Recent stories</h2>
    
  <div class="content">
    <div class="item-list"><ul><li class="first"><a href="/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process">Portsmouth Democrats urge State Party review of endorsement process</a></li>
<li><a href="/2018/06/25/portsmouth-water-releases-consumer-confidence-report">Portsmouth Water releases Consumer Confidence Report</a></li>
<li><a href="/2018/06/15/lte-address-tax-issues-third-party-rental-platforms">LTE: Address tax issues with third-party rental platforms</a></li>
<li><a href="/2018/06/13/thank-you-portsmouth">Thank you, Portsmouth</a></li>
<li class="last"><a href="/2018/06/06/tax-assessor-i-will-ensure-taxpayers-transparency">As tax assessor, I will ensure taxpayers of transparency</a></li>
</ul></div><div class="more-link"><a href="/blog" title="Read the latest blog entries.">More</a></div>  </div>
  
</div> <!-- /.block -->
<div id="block-views-landfill-block" class="block block-views">

        <h2 >Landfill capping coverage</h2>
    
  <div class="content">
    <div class="view view-landfill view-id-landfill view-display-id-block view-dom-id-53a7c4159a6d9e430042aa85b4098ebb">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
          <a href="/2016/12/20/ridem-issues-deadline-threatens-fines-portsmouth-landfill-capping">RIDEM issues deadline, threatens fines in Portsmouth landfill capping</a>        &ndash;   
          12/20/2016        &ndash;   
           2,496 views  </li>
          <li class="views-row views-row-2 views-row-even">  
          <a href="/2015/09/24/portsmouth-landfill-capping-project-enters-final-covering-phase">Portsmouth landfill capping project enters final covering phase</a>        &ndash;   
          09/24/2015        &ndash;   
           57,663 views  </li>
          <li class="views-row views-row-3 views-row-odd">  
          <a href="/2015/06/02/dem-says-portsmouth-dump-capping-now-compliance">DEM says Portsmouth dump capping now in compliance</a>        &ndash;   
          06/02/2015        &ndash;   
           5,216 views  </li>
          <li class="views-row views-row-4 views-row-even">  
          <a href="/2014/11/06/dem-catches-bad-dirt-portsmouth-landfill-cap">DEM catches bad dirt at Portsmouth landfill cap</a>        &ndash;   
          11/06/2014        &ndash;   
           6,440 views  </li>
          <li class="views-row views-row-5 views-row-odd views-row-last">  
          <a href="/2014/09/10/dem-demands-immediate-action-portsmouth-landfill-cap">DEM demands immediate action on Portsmouth landfill cap</a>        &ndash;   
          09/10/2014        &ndash;   
           7,971 views  </li>
      </ul></div>    </div>
  
      <div class="item-list"><ul class="pager"><li class="pager-previous first">&nbsp;</li>
<li class="pager-current">1 of 7</li>
<li class="pager-next last"><a title="Go to next page" href="/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process?page=1">next ›</a></li>
</ul></div>  
  
      
<div class="more-link">
  <a href="/landfill">
    more  </a>
</div>
  
  
  
</div>  </div>
  
</div> <!-- /.block -->
<div id="block-views-popular-block" class="block block-views">

        <h2 >Most popular posts of the past year</h2>
    
  <div class="content">
    <div class="view view-popular view-id-popular view-display-id-block view-dom-id-1e869d3addfb6a6ce041b67309018978">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2018/05/14/nomination-papers-submitted-portsmouth-water-board-election">Nomination papers submitted for Portsmouth Water Board election</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (7,824)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Monday, May 14, 2018 - 1:42pm</span>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2018/03/09/phs-reverses-course-no-suspension-student-walkout">PHS reverses course; no suspension for student walkout</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (3,461)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Friday, March 9, 2018 - 8:04am</span>  </div></li>
          <li class="views-row views-row-3 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/10/30/letter-portsmouth-school-administration-about-mornings-events-phs">Letter to Portsmouth school administration about this morning&#039;s events at PHS</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,833)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Monday, October 30, 2017 - 8:47am</span>  </div></li>
          <li class="views-row views-row-4 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2018/03/12/playing-sandywoods-friday-316-hope-see-you-there">Playing at Sandywoods, Friday 3/16 -- hope to see you there!</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,779)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Monday, March 12, 2018 - 8:57am</span>  </div></li>
          <li class="views-row views-row-5 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/09/12/playing-big-e-weekend-923">Playing at the Big E weekend of 9/23</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,691)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Tuesday, September 12, 2017 - 8:41am</span>  </div></li>
          <li class="views-row views-row-6 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/07/12/ri-democratic-womens-caucus-meeting-draws-nearly-100-participants">RI Democratic Women&#039;s Caucus meeting draws nearly 100 participants</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,659)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Wednesday, July 12, 2017 - 4:22pm</span>  </div></li>
          <li class="views-row views-row-7 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2018/01/03/sen-seveney-intros-bill-ban-%E2%80%98bump-stocks%E2%80%99-semi-automatic-weapons">Sen. Seveney intros bill to ban ‘bump stocks’ on semi-automatic weapons</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,527)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Wednesday, January 3, 2018 - 1:37pm</span>  </div></li>
          <li class="views-row views-row-8 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/09/18/prudence-island-water-district-sets-water-and-tax-rates">Prudence Island Water District sets water and tax rates</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,390)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Monday, September 18, 2017 - 9:03am</span>  </div></li>
          <li class="views-row views-row-9 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/09/11/sixteen-years">Sixteen years</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,343)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Monday, September 11, 2017 - 7:21am</span>  </div></li>
          <li class="views-row views-row-10 views-row-even views-row-last">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/2017/09/07/oped-lessons-harvey-ri-must-plan-flooding-mind">OpEd: Lessons from Harvey: R.I. must plan with flooding in mind</a></span>  </span>  
  <span class="views-field views-field-totalcount">        <span class="field-content"> (1,278)</span>  </span>  
  <div class="views-field views-field-created">        <span class="field-content">Thursday, September 7, 2017 - 1:57pm</span>  </div></li>
      </ul></div>    </div>
  
      <div class="item-list"><ul class="pager"><li class="pager-previous first">&nbsp;</li>
<li class="pager-current">1 of 4</li>
<li class="pager-next last"><a title="Go to next page" href="/2018/07/06/portsmouth-democrats-urge-state-party-review-endorsement-process?page=1">next ›</a></li>
</ul></div>  
  
      
<div class="more-link">
  <a href="/popular/all">
    more  </a>
</div>
  
  
  
</div>  </div>
  
</div> <!-- /.block -->
<div id="block-block-17" class="block block-block">

        <h2 >Portsmouth info</h2>
    
  <div class="content">
    <ul>
<li><a href="http://portsmouthri.com/agendacenter" target="_blank">Portsmouth Town Council Agendas &amp; Minutes</li>
<li><a href="http://www.onaquidneck.com/portsmouth.htm" target="_blank">Portsmouth links at OnAquidneck.com</a></li>
<li><a href="http://www.eastbayri.com/portsmouth/" target="_blank">Portsmouth Times (sub required)</a></li>
<li><a href="http://en.wikipedia.org/wiki/Portsmouth%2C_Rhode_Island" target="_blank"> Portsmouth on Wikipedia</a></li>
</ul>
  </div>
  
</div> <!-- /.block -->
<div id="block-block-12" class="block block-block">

        <h2 >Communities</h2>
    
  <div class="content">
    <!--<div class="xml-icon"><p><a href="/node/feed"><img src="/misc/xml.png"  alt="RSS feed" title="RSS feed" /></a></div>
<p>--></p>
<!--<a href="http://add.my.yahoo.com/rss?url=http://feeds.feedburner.com/jmcdaid" title="hard deadlines: localblogging Portsmouth RI"><p><img src="http://us.i1.yimg.com/us.yimg.com/i/us/my/addtomyyahoo4.gif" alt="" style="border:0"/></a></p>
<p><a href="http://fusion.google.com/add?feedurl=http://www.torvex.com/jmcdaid/?q=node/feed"><img src="http://buttons.googlesyndication.com/fusion/add.gif" width="104" height="17" style="border:0" alt="Add to Google"/></a></p>
<p><a href="http://feeds.my.aol.com/add.jsp?url=http%3A//www.torvex.com/jmcdaid/%3F%3Dnode/feed"><img src="http://myfeeds.aolcdn.com/vis/myaol_cta1.gif" alt="Add to My AOL" border="0"/></a></p>
<p><a href="http://www.blogged.com/directory/education"><br />
<img src="http://www.blogged.com/icons/vn_johnm68_69736.gif" border="0" alt="Education Blog Directory" title="Education Blog Directory" /></a>--></p>
<!--<a href="http://twitter.com/jmcdaid" target="_blank">Follow me on Twitter</a>--><!--<script type='text/javascript' src='http://www.dandyid.org/beta/badgewidget/badgec/user_id/404'></script>--><p><strong>Drupal Association</strong><br />
<a href="https://www.drupal.org/" target="_blank"><img src="http://harddeadlines.com/sites/default/files/Drupal_Association_ind_member_80.png" align="left" border="0" /></a><br />
<br /><br clear="all" /><br />
<strong>Support online journalism</strong><br />
If you're a fellow citizen journalist, please consider supporting the <a href="http://journalists.org/general/register_start.asp?ref=FD287126-6D0B-4357-9B17-DE51C5D7C19D">Online News Association</a>.</p>
  </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
      </aside> 
      </div>

  <footer id="footer-bottom">
    <div id="footer-area" class="clearfix">
              <div id="footer-block-wrap" class="clearfix in3">
          <div class="footer-block">
            <div class="region region-footer-first">
  <div id="block-block-19" class="block block-block">

      
  <div class="content">
    <table border="0">
<tr>
<td valign="top"><img src="/sites/default/files/preserve_small.jpg"/></td>
<td><strong>Preserve <br />Portsmouth</strong></td>
</tr>
</table>
<div class="content">
<div class="item-list">
<ul>
<li><a href="/node/569">Portsmouth Caps Big-Box Retail!</a></li>
<li>Read about the <a href="/node/506">ad-hoc moratorium committee's final meeting</a></li>
<li>Read about anti-sprawl activist <a href="/node/437">Stacy Mitchell's talk in Portsmouth</a></li>
<li>Read about the Town Council's <a href="/node/405">moratorium meeting</a></li>
<li>Visit <a href="http://www.preserveportsmouth.org" target="_blank">Preserve Portsmouth.org</a></li>
<li>Download Portsmouth's <a href="http://www.portsmouthri.com/Otherdocs/DesRev-Final012104.pdf" target=_blank">Design Review Guidelines</a> (328K PDF)</li>
<li>Learn more about <a href="http://www.portsmouthri.com/ordinances.htm" target="_blank">Portsmouth's Zoning Ordinances</a></li>
</ul>
</div>
</div>
  </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
          </div>          <div class="footer-block">
            <div class="region region-footer-second">
  <div id="block-block-21" class="block block-block">

        <h2 >PCCWatch</h2>
    
  <div class="content">
    <p>On June 5, 2007, I was <a href="/node/351">barred from a meeting of the PCC</a>. After waiting 64 days, I was <a href="/node/409">rejected by a secret ballot</a>. Could it have been <a href="/node/406">something I said</a>? </p>
<p>"I am not sure I am free to say who is a PCC member and who is not." &mdash; Larry Fitzmorris, <em>Newport Daily News</em>, pA8, 11/3/10</p>
<p>“I don’t recall us ever claiming to represent all the taxpayers of the town.” &mdash; Larry Fitzmorris, <a href="http://www.projo.com/ri/portsmouth/content/EB_PORTPCC28_09-28-07_JE7A76S.3550828.html" target=""><em>ProJo</em> 9/28/07</a></p>
<p><strong>Quis custodiet ipsos custodes?</strong></p>
<p>What happens when a civic-minded high-school student tries to attend a PCC meeting? <a href="/node/1292">Tax watchdogs bounce an Eagle Scout</a></p>
  </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
          </div>          <div class="footer-block">
            <div class="region region-footer-third">
  <div id="block-block-42" class="block block-block">

        <h2 >SF&amp;F Links</h2>
    
  <div class="content">
    <p><a href="http://madelineashby.com/" target="_blank">Madeline Ashby</a><br />
<a href="http://www.lauriechanner.com/" target="_blank">Laurie Channer</a><br />
<a href="http://craphound.com/" target="_blank">Cory Doctorow</a><br />
<a href="http://www.cloudmover.net" target="_blank">Mark Evans - Illustrator</a><br />
<a href="http://www.sfsite.com/fsf/" target="_blank"><em>Fantasy &amp; Science Fiction</em></a><br />
<a href="http://alexanderirvine.net/" target="_blank">Alex Irvine</a><br />
<a href="http://infiniteregress.tv/" target="_blank">Paul Levinson</a><br />
<a href="http://www.amazon.com/Rebecca-Maines/e/B001K8U3NA" target="_blank">Becky Maines</a><br />
<a href="http://www.markjmcgarry.com/" target="_blank">Mark McGarry</a><br />
<a href="http://davidnickle.blogspot.com/" target="_blank">David Nickle</a><br />
<a href="http://www.rifters.com" target="_blank">Peter Watts</a></p>
<!--
<a href="foo" target="_blank"><p>bar</a><br />
--></p>
  </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
          </div>        </div>
            
      <div class="region region-footer">
  <div id="block-block-47" class="block block-block">

      
  <div class="content">
    <p align="center" class="small"><a href="/blogs/john-mcdaid">Blog</a> | <a href="/fiction">Fiction</a> | <a href="/papers">Papers</a> | <a href="/music">Music</a> | <a href="/edu">Edu</a> | <a href="/about/me">About</a></p>
  </div>
  
</div> <!-- /.block -->
</div>
 <!-- /.region -->
    </div>

    <div id="bottom" class="clearfix">
      <div class="copyright">Copyright &copy; 2018, <a href="/">hard deadlines</a>. All Rights Reserved. | <a href="/privacy">Privacy and cookies</a> | <a href="/terms">Terms of use</a></p></div>
      <div class="credit">Theme by  <a href="http://www.devsaran.com" target="_blank">Devsaran</a></div>
    </div>
  </footer>

</div>






  </body>
</html>